![](https://pdfstore-manualsonline.prod.a.ki/pdfasset/a/54/a541f445-9fb9-4f25-a0bc-1f56f8658e51/a541f445-9fb9-4f25-a0bc-1f56f8658e51-bg193.png)
Configuring Layer 3 (Network) Mode
When you assign an IP address to a physical interface, you place it in Layer 3 mode.
To enable Layer 3 mode on an individual interface, use the following commands. In all interface types
except VLANs, the
shutdown command prevents all traffic from passing through the interface. In VLANs,
the shutdown command prevents Layer 3 traffic from passing through the interface. Layer 2 traffic is
unaffected by the shutdown command. One of the interfaces in the system must be in Layer 3 mode
before you configure or enter a Layer 3 protocol mode (for example, OSPF).
• Enable Layer 3 on an individual interface
INTERFACE mode
ip address
• Enable the interface.
INTERFACE mode
no shutdown
Dell(conf-if)#show config
!
interface TenGigabitEthernet 1/5
ip address 10.10.10.1 /24
no shutdown
Dell(conf-if)#
Example of Error Due to Issuing a Layer 3 Command on a Layer 2 Interface
If an interface is in the incorrect layer mode for a given command, an error message displays (shown in
bold). In the following example, the ip address command triggered an error message because the
interface is in Layer 2 mode and the ip address command is a Layer 3 command only.
Dell(conf-if)#show config
!
interface GigabitEthernet 1/2
no ip address
switchport
no shutdown
Dell(conf-if)#ip address 10.10.1.1 /24
% Error: Port is in Layer 2 mode Gi 1/2.
Dell(conf-if)#
To determine the configuration of an interface, use the show config command in INTERFACE mode or
the various
show interface commands in EXEC mode.
Configuring Layer 3 (Interface) Mode
To assign an IP address, use the following commands.
• Enable the interface.
INTERFACE mode
no shutdown
• Configure a primary IP address and mask on the interface.
Interfaces
403