wont heat blow or flame

Asked by Bob on 12/23/2008 10  Answers

ManualsOnline posted an answer 9 years, 10 months ago

The ManualsOnline team has found the manual for this product! We hope it helps solve your problem. Get the Manual Here
4 This same thing happened to me. When I turned the fireplace on only a little light would come on inside the fireplace, the rest of the controls didn't work. If you open the back(and possibly the top) of the fireplace insert, there is a fuse that looks like a tube. My fuse was burnt out. Just replace the fuse.
Was this answer helpful?
3 I have a similar problem have power to lights and the fuse is good I checked it but no heat no blower no light in fire place and no flames ???????? anyone that can point me in the right direction thanks
Was this answer helpful?
2 I have the same unit -- 33EF003GRA -- that is 9 years old now. The same thing happened -- it suddenly stopped working. No lights, heat, blower...nothing. Then I read one of the posts here about the fuse. I looked in the back on the "computer/mother board" thing and sure enough, the fuse was blown! I went to Home Depot to purchase the fuse for a mere $2, put it in, and the fireplace now works great!! This is the fuse needed: 25Amp, 125V. It is 1-1/4 inch long and 1/4 inch thick. Radio Shack should also have it.
Was this answer helpful?
0 MY HUSBAND, ELWIN WILES, BOUGHT A HEATER/BLOWER PART FROM YOU AND WE ARE HAVING TROUBLE GETTING IT TO WORK. WE FOLLOWED ALL THE INSTRUCTIONS & STILL DOES NOT WORK. WHAT DO I DO NOW?????
Was this answer helpful?
-1 My fuse is fine, but when I turn the unit on I get only a dim light inside the "wood" and thats it. No heat or blower, no other lights. The only problem I was able to find was the made in China sticker on the back.
Was this answer helpful?

Add Your Answer

Please Note: Do not submit personal information as it will be displayed online.